You are not logged in. Please login at www.codechef.com to post your questions!

×

[closed] Problem in C++ IDE in UBUNTU (Linux)

I installed Code::Block 12.11-2 in my Ubuntu (linux) system.

But i am not able to compile my programs written in C++/C.

Any body using Code::Block in linux please help me OR you can suggest me a good IDE for C/C++ programs in Ubuntu .

Happy Coding !!!

asked 15 Aug '13, 12:41

upendra1234's gravatar image

2★upendra1234
2.3k183069
accept rate: 1%

closed 15 Aug '13, 16:14

if u want to use auto-complete, u can try sublime..

(15 Aug '13, 17:37) ks_dharanish2★

You may also want to use vim.Try it,you wont regret.:)

(01 Sep '14, 23:06) semiconductor2★

The question has been closed for the following reason "The question is answered, right answer was accepted" by upendra1234 15 Aug '13, 16:14


Have you tried geany?

link

answered 15 Aug '13, 12:45

tijoforyou's gravatar image

2★tijoforyou
4.2k52364
accept rate: 15%

It is available in the software centre.

(15 Aug '13, 12:46) tijoforyou2★
2

I am installing it .. thanks @tijoforyou

(15 Aug '13, 12:53) upendra12342★

My pleasure!

(15 Aug '13, 12:55) tijoforyou2★

Do we need to configure something in geany ... because after installation i tried to write code and again same problem ... not able to compile.

(15 Aug '13, 13:05) upendra12342★
1

AFAIK, there is no need of any configuration.

First, you press the compile button. Then, you press the build button. Then, you press the execute/run button. (Press the three buttons from left in the order they appear :D )

Something like this: http://www.youtube.com/watch?v=SN8ZahFIQKw

Btw, you need to have g++ installed in your system.

(15 Aug '13, 13:16) tijoforyou2★

have you configured path of code::block to your g++ library or executor for compile source code?

link

answered 15 Aug '13, 12:57

thuvh's gravatar image

0★thuvh
161
accept rate: 0%

1

I don't know how to configure its path ...

(15 Aug '13, 13:04) upendra12342★

Thanks guys for you kind information... I was missing g++ in my system .. Now i have installed it and my all compilers are working fine.. Both Code::Block and Geany ...

Thanks @tijoforyou , @kuruma @thuvh

link

answered 15 Aug '13, 16:11

upendra1234's gravatar image

2★upendra1234
2.3k183069
accept rate: 1%

1

That's good to know :) And a tip, when in doubt about something being installed on your system or not, the terminal is your best friend, ALWAYS ;)

(15 Aug '13, 16:13) kuruma3★

Hello @upendra1234,

I've used Codeblocks once and I hated it... Now I use Geany and it all works much better...

However, it seems to me you might have a linkage problem with your IDE configurations...

I suggest you the following thing for starters. Let's compile a simple program via command-line usage:

Write a trivial "Hello World" program in a text editor, like gedit and save it as hello.cpp on Desktop or so...

Then fire up the Terminal (shortcut Ctrl-Alt-T in Ubuntu) change your current directory to desktop (usually type "cd Desktop" only) and compile the program directly on the terminal:

g++ -o hello hello.cpp -lm

(this should work without any errors or warnings)

And then do simply:

./hello

to execute it... If this works without any errors, we can fix your problem easily...

Otherwise, something might be wrong or misconfigured with your compiler...

Tell me how this works out for you... :)

Best regards,

Bruno Oliveira

link

answered 15 Aug '13, 15:58

kuruma's gravatar image

3★kuruma
17.7k72143209
accept rate: 8%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported
  • mathemetical formulas in Latex between $ symbol

Question tags:

×157
×65
×20
×6

question asked: 15 Aug '13, 12:41

question was seen: 4,650 times

last updated: 01 Sep '14, 23:06