Getting runtime error(NZEC)

in sept long challlenge
i’m getting runtime error (NZEC)
every time i submit code in python in Easy Fibonacci problem

1 Like

Same for me. Getting NZEC. Very frustrating.

i was getting it too…
take a good look at your code, you will know what you’re doing wrong :wink:

I am also getting the same , not even able to read the input by “print(input())”

EOFError: EOF when reading a line

working fine with custom inputs.
please Help…

1 Like

Hey mate , i was getting this error too in Java , but fixed it, take input as follows

Scanner sc = new Scanner(System.in);
		
        int testCases = 0;
		if(sc.hasNext())
			testCases = Integer.parseInt(sc.next());

		while(testCases!=0) {
            //If you want to take some input, use the line below as applicable.
		//int length = Integer.parseInt(sc.next());
            //Write your program logic here. 
            testCases--;
            }

I hope this helps you out…
Cheers !

1 Like

my code works in custom input … but gives error nzec when i run it

Try to think harder, there’s gotta be some mistake in your code, the Judge can’t be wrong.

i submitted the code and they accepted…but while running they gave me error

It’s a runtime error, so your code will be submitted but the verdict will be NZEC

Just a suggestion: the Fiboeasy problem is not even a programming problem it’s a maths problems. Write the fibo series down for large inputs and find a pattern for the last digits. The answer repeats itself a number of times so you can cut down on their occurences.

By the way compiler is still dead from Codechef. Worst compiler ever. Hackerrank, Hackerearth, Leetcode all far far better

1 Like

I did the same…But my solution is partially correct…will there be any change in very high values ? or %4 is enough?

Make sure your array size should be sufficient for given input .

Array of what? What do we store in that aray?

Array of anything char , int , string take care of index bounds .

I don’t know man, Everything is perfect but the Subtask 2 won’t give right answer. It gives wrong answer.

Same problem for me too bro. The 10^18 seems to be a problem for me.

I’ve tried everything and at my wits end. Can anyone guide me towards a way to get subtask 2 right? I got subtask 1 right.