Runtime Error on one testcase only

This one is a bit weird, I don’t like posting a lot about my problems here but I’m really stuck on this one. Can’t really spot the error in the problem I was solving today (it’s THOUSES), here’s the link to my submission:

EDIT: It disappears when I remove the vector part in calc function. But I don’t get why.

But I can’t spot a case in which I’m accessing non-existent memory. I’d appreciate any form of help, thanks. :slight_smile:

It might just be a simple stack overflow - there’s quite a lot of code/ local variables in your recursively-called calc function.

Thanks for your effort, it’s not the case though. I tested out moving vector outside. I’ve also tried some ridiculous things such as using set instead of vector, etc. None of that seems to work, the platform is broken. I tried copying an AC solution and it failed the same test due to RE.

Bring me my time back :cry:

@admin Problem THOUSES is broken, please fix it:

Two matching submissions give different verdict right now.

Working submission: Solution: 48896411 | CodeChef
Non-working submission: Solution: 48910085 | CodeChef

Just this?
It looks like the whole environment is broken. :sweat_smile:

1 Like

Yeah I experienced the internal error (not a Java user so fortunately didn’t have to go through the compilation error as well). It’s funny cause the submission I copied was made just about 12 hours before my first RE submission, which happened after the internal error issue, so it broke afterwards. :wink: But yeah, it’s probably connected to this in some way.

1 Like