NZEC error or possibly a bug?

I was solving the ATM problem in Python 3.6 and was stuck because of NZEC error. I tried a few solutions, but none of them worked(I used to run those solutions and get NZEC error).

but then I accidentally submitted it and got accepted.

This is the solution link.
I’ve left a few problems just because of getting NZEC error. I want to know that is it happening just with me or anyone else?

You should provide custom input before you hit run button

Yes, I’ve tried and it gives correct output. But when I run it, it gives NZEC

Since your code is asking for input, you should provide it by ticking the custom input box and entering the input manually before running the code in the IDE. When you submit the answer you do not need to provide any input because codechef takes care of it.

Since I am not checking the box for custom input, it should run against standard test cases. I’m new to codechef but I’ve solved a lot of problems on hackerrank, so I know how custom inputs work!

It will not run against standard test cases if you do not check the custom input box in codechef. It is mandatory to provide some input by yourself in codechef

Alright, I’ll try that…

Read my post carefully.

1 Like