Something wrong with codechef?

Codechef website does not load with the Vodafone network, why so??
I have tried so many times to open the CodeChef website with a good Vodafone data connection and it does not work but what is surprising is that the poor data connection of jio always opens the website.
This happens a lot is there some issue between Vodafone and CodeChef.


Bro its working fine with Vodafone network.

when I try it gives your connection was interrupted.
I am thinking of actually making a video and giving proof.

It works fine. I am also using vodafone. I think there is some network issue for you.

It works like a charm with Vodafone Idea.

@iabhishek15 have you tried applying vpn and starting it . If vpn thing works try contacting your ISP and tell them they blocked clean website . And ya i need suggestion i m new to codechef and i need rating how can i get my rating up.

It looks to me that the site is getting blocked, I will follow your advice.

For increasing the rating part, I will reply when I become atleast 5 star.