TCS NQT IBALauncher issue

I have an ubuntu OS. The IBAlauncher shows “error017: upgrading failed”, whenever I try to launch the IBALAUNCHER.

P.S. Please reply asap.

I’m also having the same issue bro… you probably have Ubuntu 20.04 LTS if i’m not wrong…
when you try to open the launcher from the terminal you will get 100+ lines of ERROR code…

ERROR with Ubuntu 20.04 was “Unable to load config.fonts file”

What i did then… i installed the Ubuntu 16.04 LTS as written by TCS that its launcher support ubuntu 14 & 16.
when i open the launcher from terminal its open fine… (NO ERROR this time)

But today from 8am to 12pm i was having my DRC test… and as i open the launcher with chrome the page i got is “YOUR DEVICE IS NOT SUPPORTED”

I don’t know why TCS has given the Ubuntu Option if they don’t allow the system other than Windows 10.

Now i’am going to install Window 10 ( but most of my win10 user friends are getting network ERROR even if they have broad band with 50+ mbps speed )
Most of them are also not able to complete the DRC test.

Do you know anything about the compilers which are used by TCS. I was willing to know about C++ compiler which they are providing is it same as what codechef provides or like old compilers like Turbo C.

Any successfully launched the assessment?

No man launcher is not working.

Which Os?

Windows 10

Can anyone help me out with this?

Not able to launch iLEON app . it gives error 017.
I have tried it on ubuntu 20, ubuntu 18. windows 10,
nothing worked

I am using windows 10 version. I am facing an error called “FATAL ERROR - failed to execute script main” while opening the downloaded IBALauncher.exe file. Can any one tell me how to reduce this issue I tried to contact them via calling, and mail but no response. Please help me to reduce this issue I have an exam tomorrow.

I don’t know why Tcs does these experiements. It is clearly visible that the launcher is unstable. I had to dual boot Windows as it never ran in Ubuntu.
Tcs can simply use hackerrank/hackerearth like every tech company uses for recruitment, but no, they will use the ugly UI app lol


Codechef And TCS NQT uses the same compiler. Both provided by sphere engine.

Hii bro, have u solved ur problem. Iam also facing same problem

Here’s a legit way to check if the installer is unstable, or you are missing something :
Create a virtual machine, if you have Windows 10, and create a virtual machine of Ubuntu 20.04, not only because it is the latest, but it differs hugely from 18.04 in terms of kernel updates. Using a virtual machine is recommended because it is a simulation of a perfect computer, in case your device has some parts damaged or not working properly.

If it works on it, there’s a problem on your device. Else, the installer’s bugged. Hope it helps.

Tom Marvolo Riddle

bhai please help me too if you know any solution to this

VM didn’t work for me. I tried to install Windows 8 VM(as i am on mac machine). It didn’t work . Error: Not enough ram (I allocated 4GB ram)

I have ubuntu 20 version, IBA launcher is working but the test is not starting no matter how much time you wait.please help!

Launcher won’t run on Ubuntu. Faced the same issue last year. Use virtualbox and install windows there.